Implementacja jednoobszarowego OSPF’a | praktyka

W poprzednim poście poznaliśmy teoretyczne podstawy dotyczące funkcjonowania OSPF, teraz czas zająć się praktyką.
konfiguracja protokolu ospf na routerach cisco

W ramach praktyki przećwiczymy tworzenie jednoobszarowego OSPF’a łączącego 2 sieci LAN. Do celów testowych wykorzystamy 2 routery oraz po 2 komputery symulujące sieci lokalne. Oczywiście jest to tylko przykładowa, bardzo prosta implementacja OSPF dla pojedynczego obszaru. Nic nie stoi na przeszkodzie, aby w pojedynczym obszarze było znacznie więcej routerów oraz urządzeń końcowych o ile nasze urządzenia mają wystarczającą moc obliczeniową.

Topologia sieci

W podanej powyżej topologii mamy 2 sieci LAN 10.0.0.0/8 i 20.0.0.0/8 oraz sieć pomiędzy routerami 192.168.0.0/24.

Adresacja wygląda następująco:

  • R1- GigabitEthernet0/0 -192.168.0.1
    •  GigabitEthernet0/1 -10.0.0.1
  • R2 – GigabitEthernet0/0 20.0.0.1
    • GigabitEthernet0/1 192.168.0.2
  • PC0 – FastEthernet0 10.0.0.2
  • PC1 – FastEthernet0 10.0.0.3
  • PC3 – FastEthernet0 20.0.0.2
  • PC4 – FastEthernet0 20.0.0.3

Podstawowa konfiguracja

R1(config)#router ospf 1
R1(config-router)#network 192.168.0.1 0.0.0.0 area 0
R1(config-router)#network 10.0.0.1 0.0.0.0 area 0
R1(config-router)#passive-interface gigabitEthernet 0/1
R2(config)#router ospf 1
R2(config-router)#network 192.168.0.2 0.0.0.0 area 0
R2(config-router)#network 20.0.0.1 0.0.0.0 area 0
R2(config-router)#passive-interface gigabitEthernet 0/1

Podane powyżej komendy wymagają kilku słów wyjaśnienia:

R1(config)#router ospf 1  – Rozpoczynamy proces OSPF o numerze 1. Równocześnie na jednym urządzeniu może funkcjonować kilka różnych procesów. Zakres id procesu mieści się pomiędzy 1 i 65,535. Identyfikator procesu nie nie jest jednoznaczny z przynależnością do konkretnej arei. Pamiętaj, że numery procesów na poszczególnych urządzeniach nie muszą być identyczne.

R1(config-router)#network 10.0.0.1 0.0.0.0 area 0 – Słówko network w tym przypadku jest wyjątkowo podstępne, ponieważ OSPF rozgłasza interfejsy, a nie całe sieci. Zastosowy tutaj wildcard mask oznacza które interfejsy należy dodać do area 0, w tym wypadku do area 0 dodajemy wyłącznie interfejs z adresem ip 10.0.0.1. Pamiętaj, że całą sieć 10.0.0.1/8 zostanie rozgłoszona poprzez LSU, nie tylko sam interfejs.

R1(config-router)#passive-interface gigabitEthernet 0/1 – Wyłącza interfejs z komunikacji w ramach ustalania sąsiedztwa w protokole OSPF oraz jego podtrzymywania.

Sprawdźmy czy konfiguracja działa. Pingujemy z PC3 do PC2.

C:\>ping 10.0.0.2
Pinging 10.0.0.2 with 32 bytes of data:
Reply from 10.0.0.2: bytes=32 time=17ms TTL=126
Reply from 10.0.0.2: bytes=32 time<1ms TTL=126
Reply from 10.0.0.2: bytes=32 time<1ms TTL=126
Reply from 10.0.0.2: bytes=32 time<1ms TTL=126
Ping statistics for 10.0.0.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 17ms, Average = 4ms

Dodatkowe komendy

R1(config)#router ospf 1
R1(config-router)#router-id 10.0.0.1

R1(config-router)#router-id 10.0.0.1 – Parametr router-id jest brany pod uwagę w procesie elekcji DR/BDR w przypadku gdy jest kilka routerów z najwyższym takim samym priotetetem. Jednocześnie router-id jest identyfikatorem urządzenia w procesie OSPF oraz na liście sąsiadów. Pamiętaj, router-id jest rozgłaszany jedynie podczas nawiązywania sąsiedztwa, w późniejszym czasie jeśli chcesz zmienić ten parametr, musisz również wyczyścić proces ospf.

R1#clear ip ospf process

R1#clear ip ospf process – Całkowicie czyści wszystkie procesy.

R1(config)#interface gigabitEthernet 0/0
R1(config-if)#ip ospf priority 50

R1(config-if)#ip ospf priority 50 – Polecenie to ustanawia wartość priorytetu interfejsu podczas elekcji DR/BDR.

R1(config)#interface gigabitEthernet 0/0
R1(config)#ip ospf cost 1586

R1(config)#ip ospf cost 1586 – Zmienia wartość kosztu przejścia pakietów przez dany interfejs. Domyślnie wartość tego parametru oblicza się dzieląc przepustowość interfejsu przez wartość referencyjną.

R1(config)#ip route 0.0.0.0 0.0.0.0 gigabitEthernet 0/0
R1(config)#router ospf 1
R1(config-router)# default-information originate

R1(config-router)# default-information originate – Nasz router rozgłasza trasę domyślną do pozostałych sąsiadów w ramach swoich swojego obszaru. Pamiętaj, że ta komenda powinna być zazwyczaj stosowana tylko na routerach ASBR – (Autonomous System Boundary Router).

R1(config)# show ip protocols

R1(config)# show ip protocols – Wyświetla informacje o wszystkich uruchomionych protokołach na routerze.

R1(config)# show ip ospf

R1(config)# show ip ospf – Wyświetla podstawowe informacje o działających procesach na routerze.

R1(config)# show ip neighbor

R1(config)# show ip neighbor – Wyświetla informacje o sąsiadach oraz ich aktualny status.

R1(config)# show ip ospf database
R1>show ip ospf database
            OSPF Router with ID (192.168.0.1) (Process ID 1)
                Router Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.0.1     192.168.0.1     965         0x80000010 0x002957 2
192.168.0.2     192.168.0.2     1041        0x80000011 0x00e38e 2
                Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
192.168.0.2     192.168.0.2     1759        0x8000000e 0x003171
19 aplikacji, które musi znać każdy sieciowiec

Blog wspiera partner diamentowy

Borg5 - Diamentowy partner bloga

Narzędziownik sieciowca

19 aplikacji newsletter

Grupa na Facebooku

Pierwsze kroki w sieciach

Najnowsze artykuły

Nadchodzi PLNOG 30!

Nadchodzi PLNOG 30!

Najstarsza w Polsce, telekomunikacyjna konferencja powraca w formie stacjonarnej. Tej jesieni, 6-7 września, daj się porwać w pasjonującą kosmiczną podróż z najnowszymi technologiami i inspirującymi rozwiązaniami. Razem z najlepszymi specjalistami rynku telco...

Czym jest chmura obliczeniowa?

Czym jest chmura obliczeniowa?

Podcast w wersji wideoSłuchaj na spotifyZ podcastu dowiesz się Czym jest chmura obliczeniowa? Jakie są zalety chmury? W jakich przypadkach warto wdrożyć chmurę? Jak nie pójść z torbami korzystając z chmury? Jak wygląda bezpieczeństwo w chmurze? Czy chmura zabierze...

bITconf 2022 – Bydgoska konferencja IT

bITconf 2022 – Bydgoska konferencja IT

bITconf 2022 – święto bydgoskiego IT  Już we wrześniu, po dwóch latach przerwy, odbędzie się największa konferencja technologiczna w województwie kujawsko – pomorskim. bITconf 2020, czyli Bydgoszcz IT conference, to konferencja organizowana przez lokalne społeczności...

Jak wygląda audyt bezpieczeństwa?

Jak wygląda audyt bezpieczeństwa?

Podcast w wersji wideoSłuchaj na spotifyZ podcastu dowiesz się Czym jest bezpieczeństwo informacji? Jak wygląda audyt bezpieczeństwa? Czym jest ISO 27001? Jak pracownicy odbierają pracę audytora? Jak przygotować się do audytu? Jak często powinien być przeprowadzany...

Model referencyjny ISO/OSI

Model referencyjny ISO/OSI

Maszyny, podobnie jak ludzie, do skutecznej komunikacji potrzebują pewnych zasad. My przestrzegamy zasad gramatyki oraz używamy słownictwa zrozumiałego dla odbiorcy, urządzenia natomiast wykorzystują standardy i protokoły. Na tym nie kończą się podobieństwa. Zwróć...

Jesteśmy partnerem  konferencji

PLNOG
Bydgoszcz konferencja IT

O autorze

Rafał Rudewicz

Specjalizuję się w rozwiązaniach Enterprise oraz Service Provider. Projektuję, wdrażam oraz naprawiam sieci dla największych firm na świecie.

Komentarze

0 komentarzy

Wyślij komentarz

Twój adres e-mail nie zostanie opublikowany.

Powiązane posty

Zapisz się na newsletter